-
Notifications
You must be signed in to change notification settings - Fork 35
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Add get_bits() definition #91
Conversation
ffv1.md
Outdated
@@ -172,6 +172,10 @@ Several components of FFV1 are described in this document using pseudo-code. Not | |||
|
|||
`byte_aligned( )` is true if `remaining_bits_in_bitstream( NumBytes )` is a multiple of 8, otherwise false. | |||
|
|||
#### get_bits | |||
|
|||
`get_bits( i )` is the action to read the next `i` bits in the bitstream and to return the corresponding value. The current position is increased by `i`. |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
nit: better term for current position
?
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I guess, I would use the term pointer
.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I reused current position
from line 169.
Should I change the term in the same PR?
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I preferred the term current position
over pointer
but ¯\(ツ)/¯
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
blank vote, need another voter.
added a commit for changing "current position" to "pointer" |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
LGTM
This definition seems unclear in relation to lest significant bit vs most significant bit in a byte first. |
55279d5
to
55e192b
Compare
PR updated with addition of |
There was no definition of this function.
Issue reported by @dwbuiten